You'll need to download our app before your trip

You'll need to download our app before you take your first trip, so you can find the car, get the keys and drive.

Can I take a trip if I don't have the app?

You won't be able to take a trip if you don't have the app.

What should I do if I’ve already booked a trip and I can’t download the app?

If you can't get the app, unfortunately, you'll need to cancel your booking. Of course, you won't be charged any cancellation fees and you'll be refunded any amount you have already paid.

  1. Log in and go to Trips
  2. Select Cancel this trip
  3. Choose Other as the reason
  4. Let us know you can't install the app

We will cancel the trip and refund any charges. 

Why isn't the app available for older operating systems?

To use our app, you will need to be using a phone running Android 7.0 (Nougat) or greater, or iOS 11 or later.

This is because newer operating systems have features available which will allow us to continue improving the app, providing a better experience with fewer bugs. Unfortunately, this means we have had to make the decision to stop supporting those older systems, in favour of providing the best experience we can.

Was this article helpful?
66 out of 114 found this helpful

Comments

3 comments
  • Locking out older system users is an appalling way to treat customers. I appreciate the associated costs of catering to older systems, but there are those of us who hang onto our phones for as long as possible because we don't want to contribute to the e-waste crisis blighting lives and ecosystems worldwide, or simply because newer phones are unaffordable...doubly so in the context of the pandemic. This sort of behaviour forces users off functional devices and contributes to the e-waste crisis. I would have thought a young company catering to budget-conscious customers, that touts its commitment to 'creating cleaner, greener, better neighbourhoods.' could do better than this.

    4
    Comment actions Permalink
  • This is absurd. I've just cancelled a trip because I couldn't use the app due to having an older phone (and it's not even February yet!). I've never had any trouble downloading and using apps--this is the first one I've tried to download that's said that it's incompatible with my phone. I also note that when I search for the Car Next Door app, other car share apps come up, including GoGet and Flexicar. Really poor decision making by CND. Complete rubbish.

    3
    Comment actions Permalink
  • Unfortunately, we had to make the decision not to support phones running older operating systems so that we could make improvements to create the best experience we can for the majority of users who are using newer phones. I'm really sorry for the frustration this has caused and hope that you're able to find a good car sharing option that works for you!

    -2
    Comment actions Permalink

Article is closed for comments.